Installing GenSim on Ubuntu 14.04

First thing you need is installation of ‘pip’ or ‘easy_install’. Kindly check for it. I was unable to use command sudo pip install gensim But I opted for download the source and install it using by going to folder where source is extracted: sudo python setup.py install Because there were unmet dependencies. One by One…

R with GRASS GIS

High quality statistic analysis in GRASS GIS is possible thanks to an interface to the most powerful statistics analysis package around: R(http://www.r-project.org). There is support for: The spgrass6 R addon package provides a convenient R ←→ GRASS GIS 6 interface The rgrass7 R addon package provides a convenient R ←→ GRASS GIS 7 interface Using…

Custom Bib

The classic way. Ref Download the custom-bib zip file and extract it (ctan link: http://www.ctan.org/tex-archive/macros/ … custom-bib). My (very old) notes on this are as follows: ============ A. Beginners Make your own BibTeX .bst style file using the package called custom-bib. First time only: run the command: latex makebst.ins. All other times run latex makebst…

Git Commands

 Git Commands First make the repository (Name=RepositoryName) on github. Open the terminal and make the new directory (mkdir NewDirectory). Copy your ProjectFolder to this NewDirectory. Change the present work directory to NewDirectory. Run these commands git init git add ProjectFolderName git commit -m “first commit” git remote add origin https://github.com/YourGithubUsername/RepositoryName.git git push -u origin master…

Inserting Code to Latex File

While working on adding source code to Latex found that a Package{listing} is of best use. I used that in my file. The best source I found on Sharelatex. For Styleing the code I used \usepackage{color} \definecolor{codegreen}{rgb}{0,0.6,0} \definecolor{codegray}{rgb}{0.5,0.5,0.5} \definecolor{codepurple}{rgb}{0.58,0,0.82} \definecolor{backcolour}{rgb}{0.95,0.95,0.92} \lstdefinestyle{mystyle}{ backgroundcolor=\color{backcolour}, commentstyle=\color{codegreen}, keywordstyle=\color{magenta}, numberstyle=\tiny\color{codegray}, stringstyle=\color{codepurple}, basicstyle=\footnotesize, breakatwhitespace=false, breaklines=true, captionpos=b, keepspaces=true, numbers=left, numbersep=5pt, showspaces=false, showstringspaces=false,…

Latex for Humans

Your Thesis is Research Finding + Typesetting. Preparing printable text effectively forces you to conflate two tasks that are conceptually distinct and that, to ensure that people’s time is used most effectively and that the final communication is most effective, ought also to be kept practically distinct. The composition of the text itself. By this…

Error Running SAGA 2.2.0 in QGIS 2.0 installed on UBUNTU 14.04

While running running SAGA 2.2.0 in QGIS 2.0 installed on UBUNTU 14.04  error i got is “Missing dependency.This algorithm cannot be run” . As still i have installed SAGA and checked through console by running saga_cmd. The issue was resolved using Go to Processing->Options and Configuration Click on Providers->SAGA Uncheck “Enable SAGA 2.0.8 compatibility” Thanks

Working with osm2pgsql 

I worked with osm2pgsql sounds impressive for converting ism to Pusalkar database based on default style. The command are availed at Wikipedia page but make sure if you are working with default user of op stares in Ubuntu, you may not have access permissions to the .osm file. Make sure that your Postgres can each…

Punjab Remote Sensing Centre, Ludhiana and Guru Nanak Dev Engineering College, Ludhiana joins hands to excel in Geo-Spatial Technologies

Guru Nanak Dev Engineering College (GNDEC), Ludhiana, the oldest engineering college of Punjab and Punjab Remote Sensing Centre (PRSC), Ludhiana, a prestigious organisation of Government of Punjab has signed Memorandum of Understating (MoU) today. The MoU signing ceremony held at Testing and Consultancy Cell, Guru Nanak Dev Engineering College, Ludhiana. The purpose of MOU is…

QGIS – Error Load Pluging due to error calling Classfactory()

I got this error and unable to load “Processing” plugin. I visited many sites but didn’t find satisfactory answer. The method worked for me is : Start Qgis. Error message will appear. Cut it and let qgis start. Go to Manage plugin Look at Red color Plugins or those need up-gradation/downgrading Do the needful and…